Credit Card Payments Issue
Incident Report for MURAL
Resolved
The fix we deployed has successfully resolved the issue and credit card payments are once again being processed correctly. Any users impacted by this issue can now re-submit their billing details to complete their subscription.

We apologize for the inconvenience this may have caused and thank you for your patience.
Posted Jun 01, 2021 - 21:45 GMT-03:00
Update
We are continuing to monitor the fix that has been deployed for this issue. We will update this message as soon as there are further details available, or at the latest within the next hour.
Posted Jun 01, 2021 - 20:45 GMT-03:00
Monitoring
A fix for this issue has been deployed and we are currently monitoring its status. We will update this message as soon as there are further details available, or at the latest within the next hour.
Posted Jun 01, 2021 - 19:42 GMT-03:00
Update
We are continuing to work on a fix for this issue. We will update this message as soon as there are further details available, or at the latest within the next hour.
Posted Jun 01, 2021 - 19:24 GMT-03:00
Update
We are continuing to work on a fix for this issue. We will update this message as soon as there are further details available, or at the latest within the next hour.
Posted Jun 01, 2021 - 18:04 GMT-03:00
Identified
We have identified the cause of the credit card payment issue. We're working on a fix that we hope to deploy soon. In the meantime, please continue to contact our Customer Support team at support@mural.co if you are unable to access your workspace due to an expired subscription.
Posted Jun 01, 2021 - 16:19 GMT-03:00
Investigating
We are currently investigating reports from a small number of MURAL users of an issue paying for a monthly or annual subscription via credit card. If you are experiencing this issue and need to access your MURAL workspace urgently, please contact our Customer Support team at support@mural.co.
Posted Jun 01, 2021 - 15:27 GMT-03:00
This incident affected: MURAL Application (Billing).