Users are unable to sign in to Mural

Incident Report for Mural

Postmortem

Date: October 29, 2025
Impact Duration: 15:55 – 21:20 UTC
Status: Resolved
Root Cause: Outage with our cloud hosting provider

Overview

On October 29, 2025, Mural experienced a major service disruption that prevented users from signing in or accessing their murals. The issue was caused by a widespread outage with our primary cloud hosting provider.

While the outage was external to Mural, it significantly impacted our ability to serve requests and maintain normal operations for several hours.

Timeline of Events (UTC)

  • 15:55 — We detected that some users were unable to sign in to Mural. Mural’s incident response team began investigating immediately
  • 16:13 — The incident notification was posted to Mural’s status page at status.mural.co 
  • 16:17 — We identified the root cause as an outage in Microsoft Azure’s infrastructure affecting application access
  • 16:32 – 20:46 — We continued working with Microsoft Azure and monitored for recovery while keeping users informed via our status page
  • 20:46 — Partial recovery began; some regions regained access
  • 21:19 — Full service restoration confirmed
  • 23:20 — Incident marked as resolved after stable monitoring and confirmation from our upstream provider

Root Cause

The outage originated from an Azure Front Door incident that disrupted network resources across several regions. This affected authentication and access for users attempting to sign in to Mural. Our systems rely on Azure for critical infrastructure, meaning our service availability was directly impacted by the Azure outage.

Resolution

We attempted several workarounds during the Azure outage, however these proved unsuccessful as the core issue required Azure Front Door accessibility. As Azure recovered, we were able to reconfigure our systems to bring Mural services back online. We closely monitored all internal systems and user traffic to ensure full stability before marking the incident as ‘in monitoring’. Once normal operation was confirmed across all regions for a period of 2 hours, we closed the incident.

What We’re Doing Next

Although this incident was triggered by an external provider, we are taking several steps to reduce the impact of similar events in the future:

  1. CDN Improvements — We are researching improvements to our content delivery network (CDN) setup to enhance resilience
  2. Enhanced Monitoring — We are expanding our monitoring systems to detect upstream provider issues faster and more precisely
  3. Communication Consistency — We are working on improving how we communicate during incidents across all channels, including our status page, marketing site, and in-app messages, to ensure consistent and timely updates
  4. Cloud Infrastructure — We continue to assess our infrastructure to mitigate any potential impact from potential future impacts to our cloud hosting provider

Closing Thoughts

We know how important Mural is for your daily collaboration and creative work. Any downtime disrupts your teams, and we take that responsibility seriously. We sincerely apologize for the inconvenience this incident caused and appreciate your patience as we worked to resolve it.

We’re committed to learning from this event and strengthening Mural’s resilience against external dependencies.

Posted Nov 04, 2025 - 10:22 GMT-03:00

Resolved

The issue with our upstream provider has been closed, and we've observed stable uptime with our system for the past few hours. This issue is now considered fully resolved.

We apologize for the inconvenience this interruption caused and will be conducting a full review to identify potential improvements for incidents of this nature.
Posted Oct 29, 2025 - 20:28 GMT-03:00

Update

Full service has been restored and users are able to log in and make use of their murals again. We're keeping this incident in a 'monitoring' status until our upstream provider closes their incident, in case there are any further configuration changes we need to react to.

We expect to pass this incident to a 'resolved' status at 23:20 UTC.
Posted Oct 29, 2025 - 18:19 GMT-03:00

Monitoring

Our service is starting to come back online and users in many regions will be able to access their murals again.

This service may remain intermittent over the next couple of hours and we're continuing to monitor the status closely with our upstream provider.
Posted Oct 29, 2025 - 17:46 GMT-03:00

Update

We're continuing to work on resolving this issue as quickly as possible. We'll provide an update as soon as there's more information available, or by 21:00 UTC at the latest.
Posted Oct 29, 2025 - 17:15 GMT-03:00

Update

Mural's incident response team continues to monitor the issue and aims to restore service as quickly as possible. We'll provide an update as soon as there's more information available, or by 20:15 UTC at the latest.
Posted Oct 29, 2025 - 15:55 GMT-03:00

Update

Mural's incident response team continues to monitor the issue and aims to restore service as quickly as possible. We'll provide an update as soon as there's more information available, or by 19:15 UTC at the latest.
Posted Oct 29, 2025 - 15:13 GMT-03:00

Update

Mural's incident response team continues to monitor the issue and aims to restore service as quickly as possible. We'll provide an update as soon as there's more information available, or by 18:15 UTC at the latest.
Posted Oct 29, 2025 - 14:29 GMT-03:00

Identified

Our upstream hosting provider, Microsoft Azure, is currently experiencing access issues which is affecting Mural. We are following this issue closely with our provider and will restore access to Mural as soon as possible.
Posted Oct 29, 2025 - 13:32 GMT-03:00

Investigating

Users are currently unable to sign in to Mural. We know this is a major service disruption for everyone. We're investigating the issue and will restore regular service ASAP.

Please check our status page for the most up-to-date info 👉 status.mural.co/
Posted Oct 29, 2025 - 13:13 GMT-03:00
This incident affected: Mural Application (Authentication, Billing, Canvas, Exports, Integrations, Mural Database, Notifications, Realtime collaboration, Search).