Users unable to log in
Incident Report for MURAL
Postmortem

What happened:
At 8:09am Pacific Time on Feb 22, 2021 we updated the IP Allowlisting settings for one of our Enterprise customers. The list of IP addresses for that customer contained an incorrectly formatted IP range, causing an exception in the code that updates our firewall settings. Our firewall configuration system responded to this exception in the most conservative manner possible, temporarily shutting off all customer access.

At 8:27am Pacific Time on Feb 22, 2021 we corrected the malformed entry and re-applied the IP Allowlisting settings for the customer in question, restoring access to the system.

What we’ve done to avoid this happening again:
At 5:14am Pacific Time on Feb 23, 2021 we published an update to our Firewall configuration system. This update provides more granular exception handling and ensures that Firewall updates will apply only to the customer being modified.

Posted Feb 23, 2021 - 14:39 GMT-03:00

Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 14:25 GMT-03:00
Monitoring
A fix has been implemented and MURAL access has been restored. We are monitoring the results.
Posted Feb 22, 2021 - 13:33 GMT-03:00
Investigating
Users are currently unable to sign in to MURAL. We're investigating the issue + will restore regular service ASAP.

Please check our status page for the most up-to-date info 👉 status.mural.co/
Posted Feb 22, 2021 - 13:23 GMT-03:00
This incident affected: MURAL Application (Authentication).