MURAL Collaboration Issue
Incident Report for Mural
Postmortem

What happened?

Realtime collaboration failed, resulting in MURAL users not being able to see other logged-in users or their actions in murals.

Summary

At 16:10 UTC on June 10th, we started to receive notifications from MURAL users of an issue with realtime collaboration. MURAL’s task force started investigating at 16:23 UTC. By 16:44 UTC a change had been deployed, restoring realtime collaboration and enabling users to see collaborators in their murals. This change was monitored over the next hour to ensure system stability, after which the incident was considered resolved.

The incident lasted for 34 minutes, with an additional 60 minutes of monitoring time to ensure the system remained stable.

Posted Aug 23, 2022 - 15:55 GMT-03:00

Resolved
The fix we implemented earlier has been successful in resolving the real-time collaboration issue and full service has been restored.

We apologize for the inconvenience this interruption caused and will be conducting a full review to avoid a repeat in the future.
Posted Jun 10, 2022 - 15:02 GMT-03:00
Monitoring
A fix has been deployed and the issue with real-time collaboration should be resolved. If you are not seeing other real-time collaborators, please refresh your browser tab. If you still do not see your real-time collaborators, please get in touch with our Customer Support team via support@mural.co.
Posted Jun 10, 2022 - 13:44 GMT-03:00
Identified
We have identified the cause of the real-time collaboration delays. We're preparing a correction to resolve this.
Posted Jun 10, 2022 - 13:37 GMT-03:00
Investigating
Some users are currently experiencing a real-time collaboration issue. We're investigating the issue. We will restore regular service as quickly as possible.

Please check our status page for the most up-to-date info: status.mural.co
Posted Jun 10, 2022 - 13:32 GMT-03:00
This incident affected: Mural Application (Realtime collaboration).