Invitation emails are not reaching destination
Incident Report for MURAL
Resolved
Invitation Emails are going through normally again.
Posted 9 months ago. May 22, 2017 - 15:37 GMT-03:00
Identified
Invitation emails are not going through. We are currently fixing the issue.
Meanwhile please use invite links to invite your teammates
Posted 9 months ago. May 22, 2017 - 14:30 GMT-03:00