Mural images may not be loading
Incident Report for MURAL
Resolved
All systems back to normal
Posted 8 months ago. Jun 23, 2017 - 13:09 GMT-03:00
Update
This problem has been reduced to the MURAL windows application, both Hub and Windows app
Posted 8 months ago. Jun 21, 2017 - 21:33 GMT-03:00
Investigating
Mural images may be loading slow or may be not loading at all on large murals
Posted 8 months ago. Jun 21, 2017 - 20:56 GMT-03:00