Sign in issues
Incident Report for MURAL
Resolved
Sign in issues were resolved. Happy collaborating!
Posted 6 months ago. Aug 30, 2017 - 11:21 GMT-03:00
Monitoring
Some are users having issues while signing in. We put out a fix and are monitoring the situation
Posted 6 months ago. Aug 30, 2017 - 11:10 GMT-03:00