Unplanned maintenance
Incident Report for MURAL
Resolved
We re-fueled our engines and are running slickly once again. Happy MURALing!
Posted over 1 year ago. Nov 11, 2016 - 16:16 GMT-03:00
Monitoring
We're performing some maintenance tasks on our servers; some of our users might experience general app slowness for a short while.
Posted over 1 year ago. Nov 11, 2016 - 14:58 GMT-03:00