Service Unavailable
Incident Report for MURAL
Resolved
We identified an issue with our infrastructure provider, and fixed it. Sorry about that!
Posted about 1 year ago. Dec 01, 2016 - 07:55 GMT-03:00
Investigating
MURAL is unavailable at the moment. We're investigating.
Posted about 1 year ago. Dec 01, 2016 - 07:44 GMT-03:00