Unplanned maintenance
Incident Report for MURAL
Resolved
Our maintenance is complete and all systems are running smoothly.
Posted almost 2 years ago. May 19, 2016 - 13:39 GMT-03:00
Identified
We're performing some unscheduled maintenance on our servers which may cause some of our users to experience intermiten slowness in our service. This won't take too long. 🛠🔩⚙💻
Posted almost 2 years ago. May 19, 2016 - 11:04 GMT-03:00