Increased timeout reports
Incident Report for MURAL
Resolved
MURAL is 100% online.
Posted over 1 year ago. Sep 23, 2016 - 11:48 GMT-03:00
Investigating
Some of our users have reported an unusual spike on Server timeouts. Our team of engineers is actively working to identify the issue and understand the course of action.

Next update expected: 30 mins.
Posted over 1 year ago. Sep 23, 2016 - 11:33 GMT-03:00