Invitation emails are not reaching destination
Incident Report for MURAL
Resolved
Invitation Emails are going through normally again.
Posted 8 months ago. Jun 15, 2017 - 19:49 GMT-03:00
Identified
Invitation emails are not going through. We are currently fixing the issue.
Meanwhile please use invite links to invite your teammates
Posted 8 months ago. Jun 15, 2017 - 18:04 GMT-03:00